EPM SaaS performance degradation on NA193 is identified

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 21:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2025 - 20:52 EDT

Identified

We appreciate your patience while we investigate an issue affecting NA193. Customers within this region may experience slowness or failure when logging into the EPM Admin console

Next Update: 30 minutes or upon earlier status change.
Posted Sep 04, 2025 - 20:44 EDT
This incident affected: USA (NA193).