EPM SaaS performance degradation on EU region is identified

Resolved

The issue affecting EPM SaaS performance degradation on EU region is resolved. We thank you for your patience and apologize for any inconvenience
Posted Jun 23, 2025 - 07:19 EDT

Monitoring

A fix has been implemented. We continue to monitor the service closely as functionality returns to normal.
Posted Jun 23, 2025 - 07:02 EDT

Update

We are continue to work on a fix on this issue.
Next Update: 60 minutes or upon earlier status change.
Posted Jun 23, 2025 - 06:45 EDT

Identified

CyberArk has identified and investigating a degradation and we are working to resolve this. We thank you for your patience at this time.

Next Update: 30 minutes or upon earlier status change
Posted Jun 23, 2025 - 06:17 EDT
This incident affected: EU (EU106, EU124, EU131, EU140, EU145, EU155, EU162, EU164, EU165, EU166, EU167, EU169, EU187, EU191, EU192, EU200, EU208).